cancel
Showing results for 
Search instead for 
Did you mean: 
Ask a Question
View your usage, get billing support and much more with the My Optus app, download it here
Highlighted
New Contributor
New Contributor

Problems with Fetch Mighty Gen3 playing through AVR

Hi out there,

Several months ago we upgraded to the gen 3 Fetch TV box.  I have this problem that randomly occurs but with increasing frequency of late.  Nearly every time  we watch Fetch TV through our AVR set up (Harmon Kardon AVR 255) the signal to the TV just goes blank.

This is infrequent for watching regular TV stations but particularly prevalent when watching streamed content, whether Stan, Netflix or on demand Free TV.

 

Only way to overcome is to switch off AVR and back on again.  In the meantime one has missed a crucial goal or part of the plot of the series or movie one was watching.

Is this some incompatibility b/w Fetch TV gen3 software which uses HDM! 2.0-2.2 and older AVR which use upto HDMI 1.4?

All cables are fine. Problem does not exist if direct connection is from Fetch to HDTV.

What is happening here???

 

All Optus suggest is check cables and resetting box back to factory reboot which I have done and is a crap, non-solution.

 

 

 

0 Kudos
Reply
5 Replies
Highlighted
Moderator
Moderator

Re: Problems with Fetch Mighty Gen3 playing through AVR

Hi @JPT, thanks for getting in touch with us. Not great to hear that you're experiencing issues with your Fetch. 


We have a useful Fetch troubleshooting page that you can check out. If you’re still needing a hand, we recommend messaging us via the My Optus app.

0 Kudos
Reply
Highlighted
Honoured Contributor
Honoured Contributor

Re: Problems with Fetch Mighty Gen3 playing through AVR

It does sound like a handshake issue with the Amp/Fetch/HDMI Cable. Which one is at fault can be hard to localise without trying different equipment. Try:

1) Connect the TV direct to Fetch. You should be able to still have the audio pass through
the TV (optical out?) into your Amp for the sound.

2) Look into the settings of the Fetch. There should be a relatively new one forcing the output to HDMI1.2 or the like. Disable or enable this and see if it helps. The Fetch had a known issue with only being able to pass though audio over HDMI to some amps due to HDMI security protocols. (although that was 100% of the time, not occasionally)
Highlighted
Crowd Champion
Crowd Champion

Re: Problems with Fetch Mighty Gen3 playing through AVR

I think you are on the right track with the HDMI 1.4 issue. 

On the Fetch Mighty, goto settings, Audio & Visual, change the HDCP to Force 1.4. 


_________________________________________________________
I’m a Yes Crowd Champion (not an Optus employee). I share my knowledge on Yes Crowd on a voluntary basis. If I answered your question, please mark it as a Accepted Solution. If I helped you out, hit that Kudos button Smiley Happy
0 Kudos
Reply
Highlighted
New Contributor
New Contributor

Re: Problems with Fetch Mighty Gen3 playing through AVR

Thank-you both as I was unaware of the ability to force HDCP 1.4 instead of auto setting under the advanced tab of Audio/Visual settings.

I have not had chance to test these settings through the AVR but as bypassing the AVR direct to TV does not show any problems, I strongly suspect that your solution is correct.
Cheers,
John
Highlighted
Moderator
Moderator

Re: Problems with Fetch Mighty Gen3 playing through AVR

Thanks for the update @JPT.

0 Kudos
Reply
Top Contributors