cancel
Showing results for 
Search instead for 
Did you mean: 
Ask a Question
Highlighted
Occasional Contributor Kurgan
Occasional Contributor

Movies Won't Play on Fetch TV

Hi,

 

I recently upgraded my plan to take advantge of the EPL offer; however, I seem to be having difficulty with Fetch TV.

 

The first box arrived about a week ago and while everything else seemed to work ok, I could not get any of the movies to play. I selected a few from the Movie Box, waited until the status bar said they were ready to play and hit the blue play button. The info screen switched to a black screen with a progress bar at the bottom, where it stayed for a few seconds before it snapped back to the info screen. I downloaded a new movie, waited until the tick appeared in the icon box and hit play - same thing.

 

I called the helpdesk and spent over an hour performing every reset possible to no avail. After running out of options, they decided to send another box out (a tatty recondidtioned one, by the looks of things) however, the same thing is happening. I've re set the new box a few times, but nothing seems to work.

 

I've run diagnostics on the box and it seems to think everything is fine. My internet speed holds steady at around 10mbps. I'm at a loss, so I thought I'd put seek some advice from the forum before I have to spend yet another hour going through various re-sets with the help desk.

 

Look forward to your responses.

0 Kudos
Reply
47 Replies
RetiredModerator Nghi
RetiredModerator

Re: Movies Won't Play on Fetch TV

Hmm. That is puzzling Kurgan. Is everything else working ok on the box? Can you view/record the streaming channels and Free to Air? When you try to watch a movie box film does it give you a countdown at all when movie will be available? Also inside the settings there is a section - Menu > Manage > Settings > Downloads which will show you any content currently downloading to your hard drive.

0 Kudos
Reply
Occasional Contributor Kurgan
Occasional Contributor

Re: Movies Won't Play on Fetch TV

Hi Nghi,

 

Thanks for the response.

 

Yes, as far as I can tell everything else is working fine. I can view and record Free to Air and streamed Catch Up channels play ok. When I select a movie, I hit the Start button. The little grey bar gives me a countdown and, after a few seconds, tells me that it's ready to play. I hit play and the box switches from the info screen to a black screen with a white progress bar at the bottom. The screen goes completely black for a few seconds before the timer thing pops up very briefly and then it snaps back to the info screen. 

 

I checked the download file and the movie is listed and displayed as downloading with another little progress bar at the side. I've tried to play it through there, but it does exactly the same.

 

If two boxes are doing the same thing, what are the odds that it's a hardware fault? What else could it be?

 

 

0 Kudos
Reply
RetiredModerator Nghi
RetiredModerator

Re: Movies Won't Play on Fetch TV

Ah ok. Can you try deleting those other downloads and trying again? How is the box connected to the modem? Is it via powerline adaptors or a direct Ethernet cable? We can try a factory reset of the box which will reformat the hard-drive. You'll lose all recordings and settings though.

0 Kudos
Reply
Occasional Contributor Kurgan
Occasional Contributor

Re: Movies Won't Play on Fetch TV

Hi,

 

Tried deleting files and factory reset with the previous box and it didn't work. I can try again with this one, but I get the feeling that I will be wasting my time. The box is connected via the powerline adaptors supplied by Optus.

 

 

0 Kudos
Reply
RetiredModerator Nghi
RetiredModerator

Re: Movies Won't Play on Fetch TV

Please try the factory reset and let us know how you go. The powerline adaptors do use your internal electrical wiring to send internet between rooms. Performance will vary depending on distance and quality of the wiring. Do you get 3 green lights on both powerline adaptors? You can try different powerpoints or even a long Ethernet cable from box to modem, just for testing.

0 Kudos
Reply
Occasional Contributor Kurgan
Occasional Contributor

Re: Movies Won't Play on Fetch TV

Tried the factory reset - same thing. All the lights on the adaptors are green and I have no way of connecting the box directly to the router at the moment - don't have a 10m long ethernet cable...

 

I had a look at the internet speed on the Downloads page and it was holding steady at around 1100kbps, so I don't think there's a problem with the internet connection.

 

 

0 Kudos
Reply
RetiredModerator Nghi
RetiredModerator

Re: Movies Won't Play on Fetch TV

Ah ok. 1100kb/s is a little low for Yes TV streaming. We do recommend 2-3Mb/s for downloads/streaming to the box. Nghi

0 Kudos
Reply
Occasional Contributor Kurgan
Occasional Contributor

Re: Movies Won't Play on Fetch TV

So, managed to borrow a long ethernet cable. Plugged it into the back of my Apple Airport Extreme router and into the Fetch TV box. Reset everything - same result. Took the connection out of the Airport and plugged it directly into the back of my Netgear DM111P modem. Again, reset everything - same result.

 

The movie has almost fully downloaded to the Fetch TV HDD, but it still won't play.

 

I noticed that the movie download speeds were exactly the same - 1100kb/s - and that was with the ethernet plugged straight from the router to the Fetch box. Is 1100kb/s the standard download speed from the movie server?

 

So, after all of this, I still don't seem to be any closer to solving the problem.

 

Any more ideas?

0 Kudos
Reply
Occasional Contributor Kurgan
Occasional Contributor

Re: Movies Won't Play on Fetch TV

So, new twist in the saga: we were able to pair the Fetch TV box with an iPhone 6 and can watch the movies we've downloaded through the phone with no problems at all. However, we still can't watch them on the TV itself. We've tried swapping the HDMI cables and ports and still nothing.

 

This is getting ridiculous. Can someone from Optus with some sort of a clue get in touch with me and help sort this out as I am unable to use the service I am paying for.

0 Kudos
Reply
Top Contributors