cancel
Showing results for 
Search instead for 
Did you mean: 
Ask a Question
For Australian Bushfire info please click here
Highlighted
New Contributor Tdahl
New Contributor

Fetch TV not working

I received my Fetch TV box yesterday and installed it today. I set it up correctly and activated it. I was watching TV through it. Then I started exploring the menu and clicked on the " my tv hub" (i think that's what it's called) button in the menu and the box switched off. The remote wouldn't switch it back on so i tried resetting the box by pulling the power cord and waiting 30 seconds before plugging it back in.

 

Nothing. No lights. No power. Nothing. The power supply is getting power because there is a little green LED lit up on it, but for some reason the box isn't getting power. 

 

Has anyone else experienced this and was able to remedy the problem or has my fetch tv box bought the farm?

0 Kudos
Reply
3 Replies
Highlighted
RetiredModerator JordanOptus
RetiredModerator

Re: Fetch TV not working

Hey Tdahl, not what should be happening with Fetch there 😕 Best to have a chat with Tech Support as we may not to organise a replacement/

0 Kudos
Reply
Highlighted
New Contributor Tdahl
New Contributor

Re: Fetch TV not working

Is there a number i can call? Every time i try to chat with someone online it says they're all busy

0 Kudos
Reply
Highlighted
RetiredModerator Hannah-L
RetiredModerator

Re: Fetch TV not working

Hey @Tdahl, the number to call would be 13 13 44. Tech Support are available 24x7.

0 Kudos
Reply