cancel
Showing results for 
Search instead for 
Did you mean: 
Ask a Question
Occasional Contributor berniemansell
Occasional Contributor

Fetch TV can not show videos on my NAS

Hi Everybody!

I just received my Fetch TV box after changing my plan just the other day. Almost everything is working fine.

The problem I am having is that I have a NAS (storage device) on my network. I can access it fine through all my devices such as mobile phones, Computers, Laptops, Playstation's etc. But when I go to My Stuff - My Media Hub - Then select my NAS - I have the folders Photo, Music, Video, When I click on either of these I get the loading symbol and it stay's on the same menu with the 3 folders  Photo, Music & Video. How can I get Fetch TV to list and be able to play the videos on my NAS? Does it need a firmware update? 

Tags (1)
0 Kudos
Reply
17 Replies
Honoured Contributor
Honoured Contributor

Re: Fetch TV can not show videos on my NAS

Maybe try this?

 

FWIW the Fetch PVR is a great PVR but not a great media player. Perhaps get a $100 media player to handle all your NAS viewing.

 

Regards

 

Peter Gillespie

0 Kudos
Reply
Occasional Contributor berniemansell
Occasional Contributor

Re: Fetch TV can not show videos on my NAS

I was prefering not to do that. As I have a PlayStation I normally used for a media player but since I now have the fetch tv box I would like to use it for all my media needs and not have to switch to another device to watch my own movies.

 

0 Kudos
Reply
Highlighted
Occasional Contributor muzza008
Occasional Contributor

Re: Fetch TV can not show videos on my NAS

Hi Bernie,

 

I'm having the exact same issue, however I've had mine for over six months now. It had worked fine all that time except the last couple of weeks. I still can't figure out why. I've tried following the instructions that PeterG suggested as well and remanaging the library of files through window media player.

 

My thoughts are that there was a firmware update on the fetch box which stuffed something up.

 

If anyone else knows something else to fix this it would be great.

0 Kudos
Reply
Occasional Contributor berniemansell
Occasional Contributor

Re: Fetch TV can not show videos on my NAS

At the moment I am in the process of setting up a home server and using it as a NAS as well. But in the process of getting Optus to give me static IP addresses the tech stuffed up my router now my business can not operate for 4 days or until the problem is fixed. It seems odd that fetch tv has this issue but once my new server is setup I will try again and let everyone know if it works or not. This will rule out any problems with my network and point directly to an issue with the fetch tv unit itself

0 Kudos
Reply
Occasional Contributor muzza008
Occasional Contributor

Re: Fetch TV can not show videos on my NAS

Any update on your progress?

 

The weekend after I made my post I was playing around with the network sharing and homegroup settings and got it working again. However, just a day or two later it was not working again. I tried playing around with the same settings but could not get it working again. It's a mystery to me.

0 Kudos
Reply
Honoured Contributor
Honoured Contributor

Re: Fetch TV can not show videos on my NAS

Its sounds like you could have an IP conflict?

 

Two devices assigned the same address (either fixed or dhcp) can result in erratic performance.

 

Maybe try disconnecting all equipment and reconnecting one at a time (starting with the one that doesn't work)

 

Also with the Fetch PVR, try AUTO and FIXED IP options in the menu.

 

Regards

 

Peter Gillespie

0 Kudos
Reply
Occasional Contributor muzza008
Occasional Contributor

Re: Fetch TV can not show videos on my NAS

Solved!

 

I know its been a while but anyway its because the problem was intermittant. Most of the time it would work, but occationally it did not.

 

The thing I noticed was in windows media player under the menu Organise>Manage Libraries>Videos where you select the location of the files you want to share over your network, when it was not working it would say "unresponsive" next to the file location on the list.

 

So I googled why this is happening and the answer was " a folder will show up as unresponsive if  it is not included as part of the Windows search index.".

 

So I then googled how to add folder or a drive in my case to windows search index and I used the instruction given in the following link (for Win10): http://www.tomsitpro.com/articles/windows-10-index-files-improve-search,2-54.html

 

So in my case the isssue is solved and I hope it helps others too.

 

Muzza008

 

 

New Contributor the_damonator
New Contributor

Re: Fetch TV can not show videos on my NAS

This may be a solution to a media server issue involving Windows , but it isn't a solution to the original question about streaming from a NAS. I'm keen to see if and how the NAS issue was solved.

0 Kudos
Reply
Occasional Contributor berniemansell
Occasional Contributor

Re: Fetch TV can not show videos on my NAS

This has not been solved. I still have this issue. It seems that they have stopped this service. I'm now using my PlayStation to access my server.

0 Kudos
Reply