cancel
Showing results for 
Search instead for 
Did you mean: 
Ask a Question
New Contributor RCKC
New Contributor

Fetch TV box setup ok but red tinted screen after couple of hours and now just red screen

I had my fetch tv box delivered last Tuesday, installed it on Anzac Day Wednesday. Setup was ok, no issue.

But then the screen had turned with a red tint. I unplugged the power plug and replugged after a minute or so. Then just had “Getting System ready ....” with a red background then blank black screen. Called Optus today, not going to any one useful. Which option to get after calling 131344? Or do I get the fetch box to a retail shop?

0 Kudos
Reply
2 Replies
Honoured Contributor
Honoured Contributor

Re: Fetch TV box setup ok but red tinted screen after couple of hours and now just red screen

@RCKC,

 

You'll need to ask Optus to send out a replacement box (livechat is 24/7 online should be all you need to do). They'll also send out a courier bag to pick up the old one.

 

Before that though, it sounds more like you might have a cable issue. Unplug and swap the HDMI cable ends. Try a different HDMI cable if you have one spare. Try a different HDMI plug in the back of your TV. 

 

Finally try a factory reset Soft then Hard

 

Regards

 

Peter Gillespie

New Contributor RCKC
New Contributor

Re: Fetch TV box setup ok but red tinted screen after couple of hours and now just red screen

Contacted livechat. New box on its way.

 

No, it’s not a HDMI issue, tech support said ethernet port issue.

Anyway, thanks.

0 Kudos
Reply