cancel
Showing results for 
Search instead for 
Did you mean: 
Ask a Question
Contributor sddawson
Contributor

Fetch TV Mighty - TV loses connection every 15-20 seconds

I just received a new Fetch TV Mighty, replacing a 2nd gen. Setup went fine, did software update etc. But now, every 15-20 seconds, my TV looks like it loses connection to the Fetch box. TV screen goes black for a few seconds, then Fetch picture returns. I have tried:

 

Restarting.

Unplugging.

Resetting to factory defaults. Problem happens even when in the setup screens.

A different HDMI cable.

 

My old Fetch box, even though it is no longer activated, displays its "not activated" screen just fine using the same connections.

 

Sound like a faulty box? If so, what do I do?

 

Thanks.

0 Kudos
Reply
4 Replies
Occasional Contributor karmar
Occasional Contributor

Re: Fetch TV Mighty - TV loses connection every 15-20 seconds

Hi,  Is this with free to air tv or on using stan or netfix.
Thanks

0 Kudos
Reply
Contributor sddawson
Contributor

Re: Fetch TV Mighty - TV loses connection every 15-20 seconds

It's with everything, even on the setup menus.

 

I did contact support, and they're sending a new box. Hopefully that will be the end of it. I'll report back when I've tested it.

0 Kudos
Reply
New Contributor termon
New Contributor

Re: Fetch TV Mighty - TV loses connection every 15-20 seconds

I have had a similar problem and found that the box had been connected to the less suitable wi-fi connection because it had a stronger signal.  The correct one is listed on our modem together with the password.  Try reinstalling with this. Good luck and I hope this helps.

Contributor sddawson
Contributor

Re: Fetch TV Mighty - TV loses connection every 15-20 seconds

My network connection was hard wired, but a replacement box fixed the problem. Thanks for the suggestion. 

0 Kudos
Reply
Top Contributors