cancel
Showing results for 
Search instead for 
Did you mean: 
Ask a Question
Welcome to the new look Community! We're still upgrading and making some changes to the platform over the coming weeks! Stay tuned.
New Contributor Wouter
New Contributor

Re: Sagemcom F@ST™ 3864V3AC Static IP page missing

I had the same issue. The reason was that I copied my MAC address from Windows IP config output, which is in the following format:

 

00-11-22-33-44-55

 

It has to be changed to the following format:

 

00:11:22:33:44:55

New Contributor KnewB
New Contributor

Re: Sagemcom F@ST™ 3864V3AC Static IP page missing

Great work.I could not get to see sessionkey in chrome or internet explorer when I tried developer options. However when I typed 192.168.0.1/lancfg2.html in the address bar and right clicked in the web page and chose to view the source,I got the session key.Then when I typed in the command http://192.168.0.1/dhcpdstaticlease.cmd?action=add&mac=(macaddres)&static_ip=192.168.0.10&sessionKey...(sesssionkey) it worked.👍👍👍

0 Kudos
Reply
New Contributor geppp
New Contributor

Re: Sagemcom F@ST™ 3864V3AC Static IP page missing

Thanks @Vigi for taking the time to investigate and share a clean solution, it was most helpful. Shame on Optus for not updating the firmware, as I'm bumping into this issue 7 months after your original post!

0 Kudos
Reply
Highlighted
New Contributor nickw1984syd
New Contributor

Re: Sagemcom F@ST™ 3864V3AC Static IP page missing

I've got to this part as well.

 

I don't suppose has figured out why we are getting: DHCP Static IP Lease Error message?

 

Any tips would be greatly appreciated.

I can't believe Optus has dropped the ball here. I can't even get through to Sagemcom.

 

THIS IS A JOKE OPTUS!

New Contributor Darkbooze
New Contributor

Re: Sagemcom F@ST™ 3864V3AC Static IP page missing

This was working for me, then support got me to factory reset my modem and all I get is 'invalid session key' now.
Grrr

0 Kudos
Reply
Occasional Contributor petros
Occasional Contributor

Re: Sagemcom F@ST™ 3864V3AC Static IP page missing

"Reset the router" will do that! I'm also waiting to fix the issue by providing the missing page.

0 Kudos
Reply
Occasional Contributor primosolada
Occasional Contributor

Re: Sagemcom F@ST™ 3864V3AC Static IP page missing

Kudus to @Vigi for a brilliant debugging and documentation.

 

The reason this is necessary is the poorly written, incomplete, and arbitrarily restricted firmware in the Sagemcom. Which is a perfect match for the bottom-of-the-barrel hardware.

 

There is a massive thread on Whirlpool about problems with this device, and circumventions.

 

'Static IP', or reservations, are only available when logged in with an administrator account. Which of course is hidden, since Optus doesn't trust its customers. There are various techniques to discover an administrator password, which are described at length in the Whirlpool thread. Unforunately not a one-size-fits-all recipe that I can post here. It also references setting the Sagemcom in bridge mode which is required if you want to use the telephony and a decent non-Sagem wireless access point.

 

But one of the techniques worked for me, I was able to open the page and enter some DHCP reservations, which served me well enough - until I acquired a decent Netgear modem/router and consigned the Sagemcom to the e-waste bin.

0 Kudos
Reply
Occasional Contributor primosolada
Occasional Contributor

Re: Sagemcom F@ST™ 3864V3AC Static IP page missing

Correction: telephony is not supported in bridge mode.

Anyone requiring this configuration has limited options:

. put up with the poor quality Sagem

. put up with some dodgy workaround

. choose a friendly provider

 

Sorry, I've been mobile-only for about 15 years and I'm not that strong on the telephony aspects. Currently with Optus, notwithstanding my non-recommendable NBN experience, because they have a shop nearby where I can't be brushed off as easily as by the online 'support'.

New Contributor PaulJames
New Contributor

Re: Sagemcom F@ST™ 3864V3AC Static IP page missing

Original post in April 2018 - 8 months ago. I had a router delivered a few days ago. I've confirmed this router is on the latest firmware.

I still can't set a static IP for an internal device. Sent to a blank screen.
Please sack the peanut working on this, and hire developers that actually create stable software.

As an amusing side note - the first three times I attempted to sign in to respond to this topic, I was met with a blank screen. I hope this peanut isn't also working on your web services.

Occasional Contributor Peterwelly
Occasional Contributor

Re: Sagemcom F@ST™ 3864V3AC Static IP page missing

Hi,thanks for posting your solution to this. Unfortunatley for those of us that are that tech savvy when it comes to this sort of thing it gets a bit much. I am going to give it a go and see what happens. My Raspberry Pi keeps vanishing from the LAN ports and I hope to be able to isolate it to its own dedicated address.

 

Why hasn't there been a response from anyone at Optus regarding this. It seems a no-brainer to allow static IP's with a home network, but you should have to be a coding specialist to be able to navigate the issue.

 

UPDATE:= I have since been told by Optus that if you turn off DHCP you can set the static IP's. the down side is that everytime the modem is restarted, you will have to start from scratch and re-enter he static IP's.

0 Kudos
Reply
Top Contributors