Searching...

Mobile

Reply

Re: AC800s constantly disconnected

nvcheeko

Well i got the same modem today and i have worked out the issue definitly a bug in the firmware its like when it drops signal to nothing it goes like this once you do a factory reset its fine again. i have had it happen 3 times after factory reset its fine but no good if you intend to travel with it. any ideas 

Highlighted

Re: AC800s constantly disconnected

Iceni

Hi NVCheeko

 

I should post a conclusion to this story.

 

TLDR it was a faulty device and I couldn't fix it myself

 

Full story - About a month after my initial posts when we reached Perth, I visited an Optus store (Fremantle) and it was sent off for assessment.  I can't quite remember all the details, but it was slow. It took them almost 2 weeks to determine it was faulty. I thought Yay I can just be given a new one, but no, I had to wait for "another" refurbished one to be completed (part delay even) and sent back.

 

We'd long since left Perth before it got sent back there, and Optus don't have the ability to redirect the returned repair to another store.... In fact you can't even call an individual store - headache! But thanks to a helpful guy instore , leaving 20 bucks and an express post envelope, I eventually received the new one in Coral bay or Exmouth or something and it actually worked great.

 

The modem itself when working was great... it did everything it said well and I couldn't be happier. Still use it now back home occasionally when traveling / staying elsewhere.

 

Optus you should

  • improve your repair assessment speed
  • consider offering new for faulty replacements
  • allow redirections for repairs
  • improve repair tracking, it was days behind reality

If you're having this issue, send off for repair as soon as you can & expect to be without it for at least a month. Optus can pause your plan so you aren't billed for the wasted time/GB until you get it back - so don't forget to do that.

Re: AC800s constantly disconnected

nvcheeko

Hi Mate 

 

Well i only recieved my brand new modem yesterday, Even after you get it working you turn it off and back again wont connect till you Factory reset, today ill go to Optus and get new one as its definitly faulty or Firmware. 

 

See what happens but no way im waiting as i only got it yesterday.

 

Thanks for your help

Re: AC800s constantly disconnected

addie_b

can i ask how you get into the interface that you have pictured in your post?

Re: AC800s constantly disconnected

Duchess29

Well I have had my device for a week, after being sold the dream of 500GB data per month.  Being a Telstra customer for a long time and very dubious about the service I went on a pre paid plan, paying over $200 for the device, plus connection and monthly fee.  Only days in, and I get the same error, can't connect, can't restart and now have to drive to an Optus shop an hour away to get it fixed.

 

Think I might just get my money back and stick with Telstra.

Post a Reply
Top Contributors
130 Kudos
127 Kudos
100 Kudos
82 Kudos
56 Kudos