cancel
Showing results for 
Search instead for 
Did you mean: 
Ask a Question
shizzy
Contributor
Contributor

Re: New Optus supplied modem - Sagemcom 5366TN

Rebooted to get latest firmware SG4Y1T0003035. I can confirm hairpinning now works, makes life a little easier when I need to access things in my network I can just use the one external IP address, instead of switching back and forth external and internal IP's depending on location.

0 Kudos
Reply
onwarril
Occasional Contributor
Occasional Contributor

Re: New Optus supplied modem - Sagemcom 5366TN

Hi, only just joined this blog, so entering at the tail end so to speak.

Within last few weeks changed over to 5366TN-A router from one of the older flat white ones, 3864OP, which was a brilliant router that worked well, it did the normal functions & had no issues with the ipsec permanent tunnels, a few L2TP tunnels when required, and PPTP connections also when required.

Initially impressed with the 5366TN with its speed. Since I have found a few issues that at the present time seems no work around available.  The previous firmware v2023 had a few issues with ipsec inconsistencies that I found; and pptp did work, with GRE forwarded on 1723 tcp to the device as a workaround.  Although it appears that the inconsistencies issues with ipsec have been resolved in the newest firmware v3035 update, the newest firmware update seems to have blocked GRE regardless of configuration.  Even the extreme workaround for GRE in v2023 no longer works in v3035.

Has anyone found a workaround to enable GRE pass though with v3035 yet?

With thanks

0 Kudos
Reply
SirLegend
Occasional Contributor
Occasional Contributor

Re: New Optus supplied modem - Sagemcom 5366TN

I have had a case logged with optus since last tuesday re not being able to connect to my work vpn (had worked for previous 12 months). Pretty sure my modem fw version updated over easter.

Am now aware of 8 diffferent people just within my company also having the same issue. (Latest case it was working last night, but not today! - also now on latest fw version. Optus techs are sending me a new modem to try (already have the nbn+4g latest version but i guess they are just following their processes). At some point they will hopefully admit there is a fw problem & figure out a fix, but i have no idea of a timeline.

In the meantime, Ive thrown a Netgear nighthawk in place of the sagecomm unit. vpn fired up again immediately. 

Have been having a bunch of discussion around it on whirlpool, but didn't want to muddy my case by discussing on here as well - now that you've indicated you seem to have a similar problem though its probably worth mentioning where i'm currently at.

0 Kudos
Reply
tonymy01
Contributor
Contributor

Re: New Optus supplied modem - Sagemcom 5366TN

Yeah, mine self rebooted a few nights ago, so looks like Optus are pushing this update (rather than previously where you had to power cycle to get the update).
Haven't tried VPN over it as it is a secondary router hanging off my main OpenWRT Linksys in case we want to use the phone.
0 Kudos
Reply
onwarril
Occasional Contributor
Occasional Contributor

Re: New Optus supplied modem - Sagemcom 5366TN

Yes, same, calls, got a replacement router exactly the same as the 5366TN, etc.  Was being transfer to another support this morning but the call dropped out and haven't been recontacted yet. So still on going.

It was necessary with both v2023 & v3035, in regards to ipsec, to do the protocols necessary directly to the relevant ports being forwarded as a workaround to get some reliability with the tunnels, eg AH etc. It appears that this workaround still works in v3035. Not like the workaround for PPTP that worked with v2023, that will not work with v3035 regarding GRE. I have not tested L2TP with this router as it is less used than PPTP for me.

Not much of a choice for me, either phones or doing work via PPTP, so I have had no option but to replace the 5366TN until the issues are resolved in the firmware regarding PPTP.  Shame, as it is a nice router with some good features, and I would love to have the issues resolved asap so I can change back to it.

I have tried the workaround to get the phones working with the temp nbn router I have in front and having the 5366TN connected via WAN port to it, but it appears that the cheap temp router I have is not possible to configure what is necessary for forwarding to the 5366TN to be able to satisfactory handle the VOIP.  It would probably work with a decent router in front configured properly.

So I guess its back to the waiting game for a new release of firmware, or a workaround can be found.

 

 

0 Kudos
Reply
DavidHarvey
Contributor
Contributor

Re: New Optus supplied modem - Sagemcom 5366TN

@onwarril  There are previous articles in this thread and others giving the details to forward port 5026 to the WAN of the F@ST5366TN so I'm not sure what you mean by "cheap temp router". 

0 Kudos
Reply
onwarril
Occasional Contributor
Occasional Contributor

Re: New Optus supplied modem - Sagemcom 5366TN

I am using as a temp router a very cheap 5 year old tlink nbn router that has had no new firmware updates available since early 2016. Does the job for basic functions including vpn, does have voip on it and two phone ports, but it appears that when you attempt to forward the necessary sip and other relevant ports fails stating that these are already in use, regardless whether ticks are in the boxes or not for those services. It may be the case that it may need defaulting and resetting up, but I just have not had the time to get back to it. Maybe over the weekend I will.

I wish to thank all who have contributed in these posts regarding this 5366TN router, as I have found this most informative and gave great incite into it, and hope that my input may be of use to some. Its a shame I have not had the time to further investigate the 5366TN to date. Thanks again

0 Kudos
Reply
SirLegend
Occasional Contributor
Occasional Contributor

Re: New Optus supplied modem - Sagemcom 5366TN

Got my replacement router yesterday afternoon. Superfast delivery so thats a good point.

Plugged it in & connected to it (before connecting to nbn. FW version SG4Y1L001019 out of the box.  Connected to nbn & my vpn immediately fired up & was operational.  

 

Have rebooted it this afternoon to see if it had been sent the new fw file. It had, and the modem is once again on fw SG4Y1L003031. Once it was back online I retried connecting to my vpn (which had been working fine all morning, but the existing problem is back & vpn connection fails once again.

Unplugged & reverted back to my temporary router solution. Issue resolved & vpn once again working. So yeah... firmware...

 

reported findings on the fault case I have logged. Waiting for a response in due course.

 

 

onwarril
Occasional Contributor
Occasional Contributor

Re: New Optus supplied modem - Sagemcom 5366TN

Update, today had a spare half hour so defaulted the old tplink $40 odd nbn temp router and reset it up but this time it accepted the port forwarding for sip etc.  Setup the 5366TN behind it with its WAN connected to the tplink and phones work again.  Thanks to those previous posts from contributors regarding the work around configuration to get phones working. Leaving the cheap tplink temp router to do the forwarding of all vpn services. Now one can work and receive phone calls.  Thanks all.

Meanwhile, hope the firmware issue is resolved in the near future.

0 Kudos
Reply
DavidHarvey
Contributor
Contributor

Re: New Optus supplied modem - Sagemcom 5366TN

@onwarril I'm glad you got it working but I'm perplexed as to why the VPN is not working for you when on the F@ST5366TN the GRE protocol is included in the "drop down" list.GRE Port Forwarding.png

0 Kudos
Reply
Top Contributors