cancel
Showing results for 
Search instead for 
Did you mean: 
Ask a Question
Shwongy
Occasional Contributor
Occasional Contributor

FTTP - Fritzbox Router with Sagemcomm Router and VOIP home phone

Hi All,

This is probably going to be a fairly lengthy post as I've already tried some of the suggestions from previous Forum posts regarding this issue and I'm going to detail everything.

This is basically the same as the posts about BYO Router with Optus NBN VOIP

Problem:
Getting the home phone which is connected to the Sagemcomm Optus Router working while using a BYO Router (Fritzbox 7490) as the primary Internet connection with FTTP

History:
I have previously got this set up working by going NBN NTD into a 5 port unmanaged switch then having the Fritzbox WAN into the Switch and also the Sagemcomm WAN into the Switch

I can't remember if I had them on separate IP address ranges but about a week ago my brother was having internet issues and had to restart everything and since then he's got internet off the Fritzbox but the phone has no dial tone, can't ring out and can't be rung.

When I checked the Sagemcomm had an IP address (192.168.0.1) on a different range to the Fritzbox (192.168.178.x), so not sure if that's how I had it set up or if the Sagemcomm has had it's config reset?

Present:
Option 1:

I factory defaulted the Sagemcomm just to reset it, turned off DHCP and turned off WiFi, connected it all back up as I had it previously via a Switch but I still don't get a dial tone on the phone.

I connected just the Fritzbox directly into the NBN NTD and I successfully get internet, I then disconnected it and directly connected the Sagemcomm into the NBN NTD and I successfully get internet and the Phone works BUT If I then disconnect both and connect them both into the Switch then the switch into the NBN NTD I keep internet but lose the Phone.
I have kept the IP Addresses of both devices on separate ranges

Fritzbox - 192.168.178.1
Sagemcomm - 192.168.0.1
Both are plugged into the switch via their own WAN port

I have also tried this set up with the Sagemcomm on the same IP Range as teh Fritzbox but no difference.

Now I am positive that I previously got this working but I do remember it being a pain in the ass and possibly there was a specific order of doing things but I couldn't get it working again, I had emailed the original forum post to myself for future reference but this is now a broken link..

Option 2:

So I looked on this forum and tried the other option:
NBN NTD into Fritzbox Router WAN then Fritzbox LAN port into Sagemcomm Router WAN
IP Addresses on the same range:
Fritzbox - 192.168.178.1
Sagemcomm - 192.168.178.2
Port forwarded 5060-5061 TCP/UDP to 192.168.178.2

Low and behold I get a dial tone! BUT when I try to call someone, I input my mobile number and I hear nothing, my mobile phone still rings though but when I answer it there's no voice on either end
I tried opening up all ports as a test and same result.

I then read about needing to Disable SIP ALG, I assume this would be done on the Fritzbox but I couldn't find a setting for it anywhere and I did read in one forum post on Whirlpool that on the 7270 this can't be done (happy to be proven wrong as I have a 7490) and I also couldn't find any setting in the Sagemcomm but I don't believe I would disable it on that device.

Thoughts:
I'm not sure what caused the problem as my brother has had to reboot the devices in the past without issue, not sure if a firmware update was applied to the Sagemcomm causing issues?
Either way, I want to get this working again as the home line is used for business purposes and I don't mind which option to go with but I'm at a bit of a crossroad.

Happy for all suggestions and thoughts and appreciate taking the time to read through this but If there is no longer a solution then I'm going to have to suggest saying goodbye to Optus and signing up with a different ISP that will allow us to use the Fritzbox with the home phone connected.

 

Thanks

Tags (3)
0 Kudos
Reply
26 Replies
YetAnotherAcc
Respected Contributor
Respected Contributor

Re: FTTP - Fritzbox Router with Sagemcomm Router and VOIP home phone


Option 2:

So I looked on this forum and tried the other option:
NBN NTD into Fritzbox Router WAN then Fritzbox LAN port into Sagemcomm Router WAN
IP Addresses on the same range:
Fritzbox - 192.168.178.1
Sagemcomm - 192.168.178.2


I assume that's the Sagemcoms LAN IP and not its WAN IP, correct?

If so then that should be the problem (assuming its not a SIP ALG/Passthrough issue).

I think you need to port forward to the WAN port which I assume is currently getting is IP address from Fritz's DHCP. So make that IP address static and port forward to it.


Port forwarded 5060-5061 TCP/UDP to 192.168.178.2


You just need 5060. The need for 5061 was based on old out-of-date info/misunderstanding.

0 Kudos
Reply
Shwongy
Occasional Contributor
Occasional Contributor

Re: FTTP - Fritzbox Router with Sagemcomm Router and VOIP home phone

Correct that 192.168.178.2 is the LAN IP of the Sagemcomm
I'm not sure that it ever gets a WAN IP but I looked at the screen about a hundred times during different set ups so I could have missed it, i'll have another look at it in that set up and see if it gets a WAN IP from the Fritzbox
Thanks!
0 Kudos
Reply
YetAnotherAcc
Respected Contributor
Respected Contributor

Re: FTTP - Fritzbox Router with Sagemcomm Router and VOIP home phone

Its listed as Public IPv4 Address under Modem Settings --> Network.

0 Kudos
Reply
Shwongy
Occasional Contributor
Occasional Contributor

Re: FTTP - Fritzbox Router with Sagemcomm Router and VOIP home phone

Thanks, I figured it would be something simple I was missing, I'll give it a try and report back
0 Kudos
Reply
Mkrtich
Super Contributor
Super Contributor

Re: FTTP - Fritzbox Router with Sagemcomm Router and VOIP home phone

Hi - I think if the Fritz!Box 7490 has been factory reset, although it is IP Dual Stacked Router, it defaults to IPv4 only on set up which may have some impact on VoIP ? - have you checked to see if IPv6 is enabled. I can't find a SIP ALG setting in the menus and other forum posts for this model also confirm your experience. 

Software Version 07.21  - Internet/Account Info/Internet Connection/IPv6.

The fact that  you got dial tone in Config 2 and could ring your mobile but have no voice implies packet loss though the SIP connection, maybe in an IPv4 to IPv6 tunnel conversion somewhere in the Internet. 

In Config 1 with the LAN Switch, when you turned OFF DHCP in the Sagecom, did you allocate it an IP address from the Fritz!Box and also put the same IP range of the Fritz!box, SAVE and Reboot the modem. 

I have a Fritz!Box 7490 configured as a secondary router on a separate sub-net for occasional testing (you have to configure say, LAN1 as a WAN port to achieve that - the Fritz!Box converts to 192.168.188.1 in that setup) and have not enabled IPv6 - I don't use the  voice applications on it.

 

 

0 Kudos
Reply
Shwongy
Occasional Contributor
Occasional Contributor

Re: FTTP - Fritzbox Router with Sagemcomm Router and VOIP home phone

Alrighty,, managed to get back to my brother's house and take a look.

Got the set up working with Optus Router WAN port into Fritzbox LAN into NBN NTD

As @YetAnotherAcc mentioned, I had missed the fact the optus router would get a WAN IP from the Fritzbox and I needed to port forward using the WAN IP address given.

I then set in the Friztbox -> Networking to continue giving the Optus Router the same IP address based on the MAC Address.

I then set up the port forwarding rules based on the Optus Router IP address.
I did have to set up for port 5060 - 5061 though, I did try just 5060 and i had the same issue where I could make a call but then I couldn't hear voice so changed to 5060 - 5061 and It all worked!

Thanks for the help guys, I'll update the main post with the resolution.
I"ll be sure to save all this info for future!

0 Kudos
Reply
Shwongy
Occasional Contributor
Occasional Contributor

Re: FTTP - Fritzbox Router with Sagemcomm Router and VOIP home phone

update, just tested making a phone call in and it doesn't seem to work, just get no tone or anything.

Any ideas?

0 Kudos
Reply
YetAnotherAcc
Respected Contributor
Respected Contributor

Re: FTTP - Fritzbox Router with Sagemcomm Router and VOIP home phone

As the Fritzbox 7490 has VoIP capability its processing 5060 by default and therefore not honouring the port forwarding. See point 2 here.

0 Kudos
Reply
JC29
New Contributor
New Contributor

Re: FTTP - Fritzbox Router with Sagemcomm Router and VOIP home phone

Hey @Shwongy ,

Did you ever get this sorted?

I'm in a similar situation as you, can't dial out or in.

I have the main router as a [R1] Fritzbox 7490 LAN#-->[R2] Sagecomm WAN (No DHCP, w/ static IP setup from [R1] for ports 5060-5061 TCP/UDP) per @YetAnotherAcc  instructions.

How'd you connect the RJ11/RJ12 line, I suppose directly to the Sagecomm?

Followed @Mkrtich #2 and turned the setting off but no luck.

0 Kudos
Reply